Formatierung deaktivieren im Editor

Forum » Feedback und Ideen » Formatierung deaktivieren im Editor


Autor Beitrag 1 2 weiter
1 2 weiter

Steppendroid

Forenbeiträge: 1137


Nach oben
28.07.2018 11:51 Uhr
Da die Formatierung des Texts im Editor durch diverse zusätzliche div-Blöcke bei jeder Bearbeitung des Beitrags ergränzt wird, wünsche ich gerne die kürzlich herausgenommene Funktion wieder zurück, in welcher man im Editor ohne automatische Formatierung schreiben kann, um diesen sehr nervigen Fehler mit diesen zusätzlichen div-Blöcken umgehen zu können.

Es ist ohnehin schon sehr nervig, dass der Editor solche Probleme macht, aber es wäre ganz nett, wenn man diese eben mit der Funktion "Formatierung deaktivieren" weiterhin umgehen können würde. Daher bitte diese Option wieder reinnehmen, oder alternativ für einen ordentlich funktionierenden Editor sorgen.

Danke!

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
28.07.2018 12:29 Uhr
Das ist mir auch gerade aufgefallen zumal man nunmehr auch nicht mehr so kopieren und einsetzen kann als vormals (z.b. zwei Zitate)

Ich möchte das bitte auch wieder zurück!

Danke!
*happiness



Nach oben
28.07.2018 12:41 Uhr
Außerdem muss ich beim Beantworten/Zitieren dann immer nochmal auf bearbeiten weil die Umlaute nicht als Umlaute sondern Sonderzeichen umgewandelt werden. Was ist das denn???

Bitte liebes Team, ändert es wieder!!! Hier ist was schief gelaufen!

Steppendroid

Forenbeiträge: 1137


Nach oben
28.07.2018 12:44 Uhr
Hmm, also das Problem mit den Umlauten stellte ich noch nicht fest. Vielleicht ist das ein ganz neues Problem bzgl. des Editors? Die Sache, dass man mit dem formatierungsfreien Editor, also dem Quelltexteditor viel besser mit Zitaten arbeiten kann, stimmt allerdings. Auch daher wäre es ganz gut, wenn man diese Funktion drin lässt.

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
28.07.2018 12:47 Uhr
Bei mir betrifft es explizit das ö und ä, aber eher spartanisch
Das kleine ö ist dann ein Ã+Pi, die anderen hab ich mir jetzt nicht gemerkt. Die Hitze halt...

Steppendroid

Forenbeiträge: 1137


Nach oben
28.07.2018 12:51 Uhr
Seltsam, also ich stellte das bislang nicht fest. Aber genauso haben andere offenbar auch das Problem mit diesen zusätzlichen Leerzeilen wie ich bei jeder Bearbeitung nicht. Hängt vielleicht vom Browser und dem Betriebssystem ab? Das würde dann mit einer schlechten Kompabilität der Forensoftware mit verschiedenen Browsern zusammenhängen. Aber ich kann auch nicht sagen wo das Problem genau liegt, da ich ja den Quellcode der Seite nicht kenne. Sicher ist nur, dass es früher alles ganz gut ging, und jetzt immer mehr solcher Probleme auftreten.

Nur wer fällt lernt zu fliegen!


Steppendroid

Forenbeiträge: 1137


Nach oben
30.07.2018 01:13 Uhr
Das nächste neue kürzlich von mir festgestellte Problem mit dem Editor:

"Es verbleiben um das Thema zu bearbeiten."

Es wird nicht mehr angezeigt wieviel Zeit noch bleibt, um einen Beitrag bearbeiten zu können. Ich möchte ja echt nicht böse sein oder herum nörgeln, aber dennoch kann ich es mir nicht verkneifen, dass ich nunmal ganz direkt sagen muss: Liebes Team, was ihr in letzter Zeit mit dem Editor macht, ist überhaupt nicht mehr schön. Ihr seid gerade dabei ein zuvor super funktionierendes System Stück für Stück kaputt zu programmieren. Dabei erklärt es sich mir auch gar nicht, warum? Es lief doch alles zuvor wunderbar; warum nun das ganze herumschnipseln am Code?

PS: Diese Doppel-Leerzeilen kann ich ohne diese "Fomatirung deaktivieren"-Funktion nicht mehr entfernen. Ich kann also nur noch doppelte Leerzeilen machen, sobald ich einen Beitrag im nachhinein bearbeiten möchte.

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
30.07.2018 07:02 Uhr
Ich versteh das auch nicht so recht. Zumal die Fehlersuche ja dann auch immer komplizierter wird. Am besten ist, alles wieder auf -seit wann ist der Mist?- davor zu setzen. Denn die nächste Fehlerbehebung wird weitere mit such ziehen. Wirklich schade! War alles top!

P.S. Es werden auch die smileys nicht alle als smile sondern Zeichen übernommen. 'eek' ist bei mir immer 'shock' und olle 'cool' kommt ohne eigene Codeeingabe immer als 8-) Ebenfalls schade. Die Dinger find ich absolut knorke, funktioniert aber nicht. Weder am Rechner noch am Handy.

Steppendroid

Forenbeiträge: 1137


Nach oben
30.07.2018 15:23 Uhr
Das liegt ebenso an der Formatierung, die diese Codes also z.B. dieses 8-) durch einen Bildlink zum Smilie ersetzen soll. Deaktiviert man die Formatierung, sieht man das und kann damit zudem kontrollieren, ob die Smilies nun wirklich funktionieren oder nicht. Also ein weiterer Punkt, warum diese Funktion sehr hilfreich ist.

Achja, das sind die Links zu den Smilies: https://www.berlinersingles.de/images/smileys/icon_wink.gif

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
31.07.2018 13:46 Uhr
Hallo Team,
bitte bitte arbeitet an den Formatierungen! Es macht einfach keinen Spaß mehr wenn man ständig die Umlaute korrigieren muss. Und korrigieren macht langsam auch keinen Spaß mehr weil man nicht richtig korrigieren kann. Mal geht's, mal nicht. Setze ich dann ein smile am Ende meines Beitrages (welcher ausnahmsweise auch mal funktioniert), ist der Text komplett weg...

Leute es nervt!!!

Eis

Forenbeiträge: 1668


Nach oben
31.07.2018 20:30 Uhr
Erst denken, dann sorgfältig schreiben. So erspart man sich das Editieren

Stadtwanderer

Forenbeiträge: 94


Nach oben
31.07.2018 20:33 Uhr
äöü ÄÜÖ ßßß âê

dick

Mal Testen......keine Probleme (LINUX Suse-Tumbletweed aktuell 30.7.2018, Firefox 61.0.1 64 Bit)

Das einzige Manko sind die Leerzeilen, die nach der Korrektur eingeschoben werden. Und natürlich die Formatierung. Allerdings werden Takes auch aktzeptiert, wenn sie von Hand eingegeben werden...
*happiness



Nach oben
31.07.2018 21:42 Uhr
Danke für eure konstruktiven Beträge!
*happiness



Nach oben
31.07.2018 21:44 Uhr
Holunder70 hat folgendes geschrieben:
plus @happys Frage: Die Leute müssen die Uberozean-Äpfel kaufen, weil es kaum heimische Sorten gibt im Supermarkt. Ich meine viele wissen, wie blöde es ist , Äpfel aus Papua-Brasilien zu kaufen und, dass es keine Bio-Äpfel sein könnte. Wenn grad kein anderer Markt aufhat , man schnell zwischen Arbeit und Kindergarten und Haushalt.achen oder irgendwie so, dann muss man die Äpfel nehmen...vielleicht mit nen scheelen Blick...und umweltbesogt, aber man braucht sie vielleicht einfach zuhause.

@stadt+@eis: Erstaunlich dass es nicht nur mir so geht... Ihr Profis!

(gerade 8 Leerzeilen entfernt...)

Holunder70

Forenbeiträge: 3486


Nach oben
31.07.2018 21:45 Uhr
Nein, es geht auch mir so!

Wende dein Gesicht immer der Sonne zu, dann fallen die Schatten hinter dich.

*happiness



Nach oben
31.07.2018 21:49 Uhr
Wie ich solche Klugscheißerein liebe...
saendmaen



Nach oben
31.07.2018 21:59 Uhr
Warum sollte man die Klugscheißereien der Anderen lieben , produziert man n , aber auch Frau ,

doch selbst genug davon.

Steppendroid

Forenbeiträge: 1137


Nach oben
31.07.2018 22:08 Uhr
Also Stadtwanderer nutzt eine sehr ähnliche Kombination wie ich: Linux + Firefox
Ich nutze Linux Mint 18.3 (frisch mit allen Updates versorgt) und Firefox 61.0.1 (64-Bit)
Ich habe genau die selben Probleme wie er, aber nicht die, wie sie Happi und Holunder es ganz offensichtlich haben.
Vermutlich nutzen Happi und Holunder kein Linux, sondern gfs Win 10 und den Chrome-Browser, also eine andere Kombi, in welcher eben diese Probleme mit den Umlauten auftreten.
Was ich nun seit heute feststellte ist, dass neue Beiträge gerne mal kurzzeitig ganz nach oben in einem Thema geschoben werden und die Namensspalte mit dem Benutzernamen und Bild etwa 80-90 % der Breite der Beitragsfläche einnimmt, sprich der Text ganz rechts in einer schmalen Spalte angezeigt wird. Erst wenn ich die Seite 1-2 mal aktualisiere, wird es wieder korrekt dargestellt.

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
31.07.2018 22:09 Uhr
Was dich betrifft gebe ich dir gern recht. Falls du mich gemeint haben solltest - worin habe ich provoziert? Nenne Pferd und Reiter, wie du es selbst gern wünschst! Oder sag was zum Thema! Oder noch einfacher, gib ganz einfach Ruhe.... DANKE

Steppendroid

Forenbeiträge: 1137


Nach oben
31.07.2018 22:10 Uhr
Diese Quellcode-Tags kenne ich nicht auswendig, da sich das Forum nicht den üblichen Tags bedient, wie es andere Forum benutzen. [quote]Zitat[/ quote] geht also nicht.

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
31.07.2018 22:12 Uhr
Die Zitierfunktion hat auch keine Rahmen mehr und es wird auch ständig angezeigt, dass ein neuer Beitrag geschrieben wurde. Aktualisiere ich es, ist bei mir kein neuer Beitrag zu sehen. Aber oben auf der Seite als erstes sind dann massig Leerzeilen, ähnlich wie du @stepp es gerade beschrieben hast, jedoch ohne Text...
*happiness



Nach oben
31.07.2018 22:15 Uhr
Steppendroid (@Steppendroid) hat geschrieben:
Diese Quellcode-Tags kenne ich nicht auswendig, da sich das Forum nicht den üblichen Tags bedient, wie es andere Forum benutzen. [quote]Zitat[/ quote] geht also nicht.
Doch, sonst ja. Damit habe ich sonst auch gearbeitet. Geht ja aber nicht mehr. Und hier in dieser Antwort ist die Zitierfunktion wieder da... (der grau hinterlegte Kasten). Beim "Apfel" sind die zitierten Texte nicht grau hinterlegt.

Steppendroid

Forenbeiträge: 1137


Nach oben
31.07.2018 22:59 Uhr
Ja, das fiel mir auch schon länger auf, dass Zitate am Ende nicht mehr im grauen Kasten sind. Das Problem ist mir schon länger aufgefallen, ich dachte bislang halt nur, dass die Benutzer das selbst irgendwie verbockt hätten. Damals dachte ich noch nicht, dass es am Forumskript selbst liegen könnte.

Was das andere betrifft, nun, wie wir wissen, stellt hier jeder viele verschiedene Probleme fest, aber manche betreffen nur die einen, manche nur die anderen und manche betreffen alle in zumindest ähnlicher Form. Es wäre ganz nett, würde das Team mal dazu Stellung nehme. Ein "Wir sind uns dieser Probleme bewusst und arbeiten daran" wäre ja schon mal etwas diese Angelegenheit entspannend.

Nur wer fällt lernt zu fliegen!


Steppendroid

Forenbeiträge: 1137


Nach oben
31.07.2018 23:01 Uhr
testmensch (@testmensch) hat geschrieben:
Ich mache ein Test-Zitat
Geht das?

Edit: Okay, [quote] geht nicht, es geht nur ein [quote = Text] (ohne Leerzeichen).

Nur wer fällt lernt zu fliegen!


Team

Forenbeiträge: 146


Nach oben
01.08.2018 15:17 Uhr
Vielen Dank für eure Hinweise.
Die Formatierung kann nicht mehr deaktiviert werden, denn das Umschalten und die unterschiedlichen Einstellungen haben unter anderem zu den Fehlern mit Zitaten geführt. Die Funktion war eigentlich nur für ältere Browser gedacht und notwendig.
Den Fehler mit den Umlauten haben wir gerade behoben.

Steppendroid

Forenbeiträge: 1137


Nach oben
01.08.2018 17:40 Uhr
Aber man kann trotzdem weiterhin mit den Codes wie [quote] etc. schreiben?
Denn das macht das Zitieren beispielsweise einfacher und besser.

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
01.08.2018 18:11 Uhr
Mich befriedigt die Antwort rein gar nicht. Es waren ja nicht nur die beiden Aspekte, die oben angesprochen wurden. Die Formatierung hat sonst auch nicht zu diesen Irritationen geführt und war seit Jahren aktiv. Warum soll das jetzt zu den Fehlern geführt haben? Wirklich schade, denn so ist es nicht mehr möglich, mehrere Antworten zu splitten - jedenfalls wüsste ich jetzt nicht so recht wie.

Steppendroid

Forenbeiträge: 1137


Nach oben
01.08.2018 20:49 Uhr
Sehe ich auch so. Ich bin seit bald 2 Jahren dabei und es gab nie Probleme mit dieser Funktion (und dem Editor ganz allgemein), im Gegenteil, es hat vieles verbessert. Die Entfernung dieser Funktion hat zudem die Fehler ja nicht behoben, sondern nach der Entfernung traten diese Problem Großteils erst auf. Im Grunde müsste man den Editor einfach nur wieder auf den Stand zurücksetzen wie er Anfang des Jahres war, denn da lief ja noch alles ganz gut.

Verstehe letztendlich nicht, wieso überhaupt am Editor herumgebastelt wird. Never change a running system - diesen Spruch gibt es nicht grundlos.

PS: Es werden immer noch mit jeder Bearbeitung neue div-Blöcke eingefügt. Ich habe auch keine Lust mehr, diese nun ständig zu entfernen, was ja ohne den Quelltexteditor nicht mehr 100%ig geht. Ein div-Block bleibt immer übrig. Dann müssen alle einfach damit leben.

Nur wer fällt lernt zu fliegen!

*happiness



Nach oben
01.08.2018 21:22 Uhr
Wie man sieht, sind die Fehler nicht behoben...

Steppendroid

Forenbeiträge: 1137


Nach oben
03.08.2018 02:26 Uhr
Irgendwie befürchte ich, dass wir nie wieder diese im Titel benannte Funktion bekommen werden.
Und diese ganzen Fehler bleiben wohl auch noch lange bestehen, weil es sich sehr sicher um so ganz tief im Code versteckte Fehler handelt, die man ewig lange nicht finden kann. Das kenne ich sehr gut, weil ich mal einen Taschenrechner mit vielen Rechen-Funktionen und einer dreigeteilten eigentlich sehr innovativen Anzeige in C# schrieb, der am Ende in der Version 1.0 alles genauso machte, wir er es sollte. Aber nach langer Zeit der Benutzung kam es doch vor, dass der Rechner abstürzte. Ich versuchte den Fehler irgendwie zu reproduzieren, aber es gelang mir nie. Ich weiß bis heute nur, dass der Fehler nach einer langen Kette von Aktionen in meinem Rechner aufkam. Es gab also irgendeine Folge von Aktionen im Rechner, der diesen zum Absturz bringt. Aber obwohl ich alle möglichen Kominationen im Rechner durchführte, konnte ich diesen Fehler nie wieder reproduzieren. Letztendlich fand ich den Fehler einfach nicht und konnte diesen daher auch bis heute nicht beheben. Der ist so tief im Code, dass er einfach nicht auffindbar ist. Natürlich könnte ich jetzt am ganzen Code herumdoktern, aber am Ende mache ich damit sehr sicher viel mehr kaputt als dass ich damit behebe. Damals begriff ich eben, dass ich lieber diesen kleinen Fehler akzeptiere, anstatt mein ganzes Programm kaputt zu machen, nur im diesen kleinen ohnehin fast nie auftretenden Fehler auszumerzen. Ich lernte damals sehr gut, dass kein Programm perfekt ist und nie perfekt laufen wird, es daher ganz gut ist, es einfach so zu belassen wie es ist, wenn es für den gewöhnlichen Einsatzbereich zu 99,99 % perfekt funktioniert.

Der Editor des Forums funktionierte bisher aus meiner Perspektive tadellos. Mag sein, dass es dort eben tatsächlich so einzelne kleinere, aber selten auftretende Fehler gab. Ebenso wie in meinem Rechnerprogramm. Aber in der Praxis funktionierte alles sehr gut. Das schließt auch diese genannte Funktion "Formatierung deaktivieren" ein. Dass das ganze in der Praxis sehr gut funktionierte und gut zu gebrauchen war, bestätige ja nicht nur ich. Dass es in der praktischen Nutzung keine wahrnehmbaren oder störenden Probleme damit gab, können sicherlich mehr Nutzer hier bestätigen. Der Editor funktionierte so, wie er war, sehr gut und ohne wahrnehmbare Fehler.

Das ganze war so, bis nun ganz offenbar am bestehendem Code herumgedoktor wurde, diese Funktion entfernt wurde und was sonst noch damit gemacht wurde. Jetzt häufen sich die Fehler. Dieser Umlautfehler war der letzte, der aufkam, wurde offenbar zwar behoben, aber es gibt noch zahlreiche Fehler, die seither bestehen, aber nicht gelöst wurden. Zudem nahm man den Nutzern die Möglichkeit, Zitate frei und individuell in den eigenen Antworttext einbauen zu können. Es ist ganz direkt gesagt ganz klar schlechter geworden, seit dem man diese Funktion ganz ohne Vorwarnung entfernt hat.

Ich möchte keineswegs böse sein oder sonst wie eine böse Absicht des Team unterstellen, oder sonst wie das Team kränken. Mein Anliegen ist nur, dass man einfach versteht, dass es vorher alles besser lief und benutzerfreundlicher war. Daher wäre es besser, diese Funktion wieder zu implementieren. Noch cooler wäre es natürlich, wenn man direkt mit einem Reiter zwischen Quellcode und Editor hin und her wechseln könnte, das ebenso in der Schnellantwort. So manche Foren bieten diese Funktion, was ich sehr zu schätzen weiß. Aber das muss jetzt nicht sofort sein, wichtiger ist erstmal, uns wieder das zu geben, was wir schon hatten. Ich meckerte da bislang auch nie, dass es nicht so super gut ist, wie in anderen Foren, weil es eben schon gut ist, dass man so eine Funktion überhaupt hat.

In diesem Sinne bitte ich aus tiefsten Herzen, macht diese Funktion, wie sie bislang war, wieder rein!

Nur wer fällt lernt zu fliegen!




Jetzt kostenlos registrieren

Einfach anmelden und verlieben!


  • Eigenes Profil mit Bildergalerie erstellen

  • Besucher des eigenen Profils sehen

  • Persönliche Nachrichten erhalten

  • Profilfoto anderer Mitglieder sehen

  • Persönliche Favoritenliste erstellen

Aktuelle Themen in anderen Foren  
Das Berliner Singles Forum Ein frischer Morgengruss vom saendmaen
Events ARTlantica- "Leben wie Gott in Frankeich"
Sportforum Berliner / Brandenburger Fussball
Plauderecke 10 Jahre Hofbräu Berlin am Samstag, 10.11.2021
Diskussionen Markus Lanz
Philosophie & Poesie Humor
Reisepartner finden Teilzeitwandern in Gemeinschaft an die Algarve 202
Flohmarkt Suche wo ist denn noch ein Flohmarkt offen??
Flohmarkt Biete Karte für den Friedrichstadtpalast